当前位置:首页 >  配资问答

带箭头macd指标

我来帮TA回答

求通达信macd指标中包含:顶底背离、金叉死叉、macd上升红色下降绿色带箭头,谢谢!

{通达信MACD顶底背离指标---供参考!}

DIFF:EMA(CLOSE,12)-EMA(CLOSE,26);

DEA:EMA(DIFF,9);

MACD:2*(DIFF-DEA), COLORSTICK,LINETHICK2;

STICKLINE(MACD>REF(MACD,1),0,MACD,1,0),COLOR0000FF;

STICKLINE(MACD<REF(MACD,1),0,MACD,1,0),COLOR00FF00;

DRAWICON(REF(MACD,2)>REF(MACD,1) AND MACD>REF(MACD,1),MACD-0.2,1);

DRAWICON(REF(MACD,2)<REF(MACD,1) AND MACD<REF(MACD,1),MACD+0.2,2);

低位金叉:=CROSS(DIFF,DEA) AND DIFF<-0.1;

STICKLINE(低位金叉,0,0.08,6,0),COLORYELLOW;

DRAWTEXT(低位金叉,0.16,' 低位金叉'),COLORWHITE;

JCCOUNT:=COUNT(CROSS(DIFF,DEA),BARSLAST(DEA>=0));

二次金叉:=CROSS(DIFF,DEA) AND DEA<0 AND COUNT(JCCOUNT=2,21)=1;

STICKLINE(二次金叉,0,0.06,6,0),COLORFF00FF;

DRAWICON(二次金叉,DEA*0.9,5) ;

DRAWTEXT(二次金叉,0.2,' 二次金叉'),COLORYELLOW;

死叉:=CROSS(DEA,DIFF);

DRAWICON(死叉,DIFF+0.2,6) ;

金叉:=CROSS(DIFF,DEA);

DRAWICON(金叉,DEA-0.2,17) ;

A1:=BARSLAST(REF(CROSS(DIFF,DEA),1));

底背离:=REF(CLOSE,A1+1)>CLOSE AND DIFF>REF(DIFF,A1+1) AND CROSS(DIFF,DEA);

STICKLINE(底背离,0,0.03,6,0),COLOR00FF00;

DRAWTEXT(底背离,0.12,' 底背离'),COLORFF00FF;

A2:=BARSLAST(REF(CROSS(DEA,DIFF),1));

顶背离:=REF(CLOSE,A2+1) AND CROSS(DEA,DIFF);

DRAWTEXT(低位金叉 AND 二次金叉 AND 底背离,0.25,'进场'),COLOR0000FF,LINETHICK2;

外汇mt4中macd带买卖箭头提示的指标,求一个?

这个一般的MT4上都找不到,基本用途不大,其实目前MT4上的各类指标能够根据自己的交易经验结合使用一两种就已经足够了。

通达信MACD公式,请高手请把下面指标公式里的金叉死叉+个箭头表示谢谢

DIFF:EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:EMA(DIFF,9);
MACD:2*(DIFF-DEA), COLORSTICK,LINETHICK2;
低位金叉:=CROSS(DIFF,DEA) AND DIFF<-0.1;
STICKLINE(低位金叉,0,0.08,6,0),COLORYELLOW;
JCCOUNT:=COUNT(CROSS(DIFF,DEA),BARSLAST(DEA>=0));
二次金叉:=CROSS(DIFF,DEA) AND DEA<0 AND COUNT(JCCOUNT=2,21)=1;
STICKLINE(二次金叉,0,0.06,6,0),COLORFF00FF;
DRAWICON(二次金叉,DEA*0.9,1) ;
DRAWTEXT(二次金叉,0.1,' 二次金叉'),COLORYELLOW;
DRAWICON(CROSS(DIFF,DEA),DEA*1.02,1);
DRAWICON(CROSS(DEA,DIFF),DIFF*0.98,2);
A1:=BARSLAST(REF(CROSS(DIFF,DEA),1));
底背离:=REF(CLOSE,A1+1)>CLOSE AND DIFF>REF(DIFF,A1+1) AND CROSS(DIFF,DEA) AND DIFF<0;
STICKLINE(底背离,0,0.03,6,0),COLOR00FF00;
底背:DRAWLINE(A1=0,DEA,底背离,DEA,0),COLORRED,LINETHICK4;
DRAWTEXT(底背离,DIFF,' 底背离'),COLORFF00FF;
A2:=BARSLAST(REF(CROSS(DEA,DIFF),1));
顶背离:=REF(CLOSE,A2+1)<CLOSE AND REF(DIFF,A2+1)>DIFF AND CROSS(DEA,DIFF);
顶背:DRAWLINE(A2=0,DEA,顶背离,DEA,0),COLORGREEN,LINETHICK4;

帮我编一个金叉死叉,带箭头提示的macd副图,要大智慧的

INPUT:SHORT(12,5,40),LONG(26,20,100),M(9,2,60);
DIFF : EMA(CLOSE,SHORT) - EMA(CLOSE,LONG);
DEA : EMA(DIFF,M);
MACD : 2*(DIFF-DEA), COLORSTICK;
DRAWICON(CROSS(DIFF,DEA),DEA,7),ALIGN1;
DRAWICON(CROSS(DEA,DIFF),DEA,8),ALIGN1;
_______________________________________________________________
说明:
第一行是参数定义;
中间三行是MACD指标;
最后两行是画金叉死叉;(如已有MACD指标,只要复制这两行就可以)

如何判断MACD的顶背离和底背离

MACD背离主要分为DIF背离和红绿柱背离。这两种情况,可以同时出现,也可以只出现一种。MACD产生背离原理是短期均线跟随股价反映速度快于起中长期均线,即中长期均线较短期均线具有有稳定性和滞后性。具体是EMA12较EMA26反映快,DIF较DEA快。
MACD顶背离是在经一个回调浪连接的两个相临上升浪的关系上,因买入力度减弱引起第二个上升浪上升速度变缓,小于第一个上升浪的上升速度,从而引起短期的EMA12比EMA26上升速度变缓出现其差值DIF的顶背离,或引起DIF较DEA上升速度变缓出现其差值红绿柱的顶背离。
MACD底背离则是在经一个反弹浪连接的两个相临下跌浪的关系上,因卖出力度减弱引起第二个下跌浪下跌速度变缓,小于第一个下跌浪的下跌速度,从而引起短期的EMA12比EMA26下跌速度变缓出现其差值DIF的底背离,或引起DIF较DEA下跌速度变缓出现其差值红绿柱的底背离。
MACD顶背离意味着行情回调、转入盘整区间或反转三种可能,反转不是唯一选择。
MACD底背离意味着行情反弹、转入盘整区间或反转三种可能,反转不是唯一选择。

MACD指标的背离怎么看?

你好。MACD指标背离有2种情况:
1,:是MACD背离是看DIF白线和DEA黄线的背离 有顶背离和底背离。
2:是MACD背离是看柱体的背离也就是峰柱的背离,也有顶背离和底背离。
以上2种第一种是用的最多的情况 也是准确性比较高的